Eurobattle.net Client Requirements

From Eurobattle.net WiKi
Jump to: navigation, search

Our server currently runs the 1.28.5 version of Warcraft III.

We provide our service for everyone, so you do not need to have a licensed copy of Warcraft III in order to play on Eurobattle.net.

Please make sure to have the following in order to be able to play on our server:

Note that version switcher isn't needed anymore, if a patch is required it will be downloaded and applied by our Client automatically.